From cb756a7202f7dffa4bdf722a521804477c79d780 Mon Sep 17 00:00:00 2001
From: Tres Seaver <tseaver@palladion.com>
Date: Fri, 05 Apr 2013 18:03:34 +0200
Subject: [PATCH] Denote ReST.

---
 setup.py |    6 ++++--
 1 files changed, 4 insertions(+), 2 deletions(-)

diff --git a/setup.py b/setup.py
index 40c1208..5a21ae2 100644
--- a/setup.py
+++ b/setup.py
@@ -17,10 +17,11 @@
 from setuptools import setup, find_packages
 
 here = os.path.abspath(os.path.dirname(__file__))
-README = open(os.path.join(here, 'README.txt')).read()
-CHANGES = open(os.path.join(here, 'CHANGES.txt')).read()
+README = open(os.path.join(here, 'README.rst')).read()
+CHANGES = open(os.path.join(here, 'CHANGES.rst')).read()
 tests_require = ['WebOb', 'zope.interface']
 testing_extras = tests_require + ['nose', 'coverage']
+docs_extras = tests_require + ['Sphinx', 'repoze.sphinx.autointerface']
 
 setup(name='repoze.who',
       version='2.2dev',
@@ -63,5 +64,6 @@
       """,
       extras_require = {
         'testing': testing_extras,
+        'docs': docs_extras,
       },
 )

--
Gitblit v1.9.3